Global Cloudflare Outage

Incident Report for Deliverect

Resolved

The incident has been resolved and our services and products are fully operational again.
Posted Dec 05, 2025 - 10:20 CET

Monitoring

A fix has been implemented by Cloudflare and our systems are recovering, we are monitoring closely.
Posted Dec 05, 2025 - 10:15 CET

Investigating

We are currently investigating a major, global outage reported by our cloud provider, Cloudflare. This outage is affecting their network infrastructure, which is severely impact the availability, performance, and accessibility of some of our products and services.
Posted Dec 05, 2025 - 10:09 CET
This incident affected: API, Deliverect Manager App, Management Portal, Click & Collect, Pulse, Catalog Push, Quest, and Dispatch.